Thread: Add-ons not working due to certificate expiration

@TomP, we have to find a way to prevent Firefox to do its check list at startup.
As @freaktechnik said, every time we run FF, it checks all add-ons installed, locally and at server side.
I’m looking for a way to avoid that. To prevent FF to take decisions on my behalf.
I’m the right person to know what is better for myself. Not anybody else.

1 Like

More than just at startup. When I first experienced this several days ago, it was in a browser that I was using and had been open for about three days. I suspect that it also has a periodic check of some nature.

@grenouille7777, it sounds like a malicious code, like a real virus!
It’s very annoying that all we must to have a “father” to decide what we are allowed to use or not.
Too much easy if FF would leave everyone decide for himself…

Congrats! You guys have killed Firefox…guess it’s the day I have to move to Chrome…ughhh…thanks a lot…all my daily extensions are declared dead by you guys…so until you fix that, you’re declared dead/dying to me!

1 Like

Perhaps, from a certain point of view. But is it really any different from what Apple and Google do with iOS or Android apps? Or even the various Linux repositories to an extent? Well, maybe not with Linux as the checks don’t continue after installation…

Please make sure you’re on the latest version of Firefox, and if that doesn’t fix the issue, hang tight for announcements in [FIXED] Certificate issue causing add-ons to be disabled or fail to install

Agree totally. What’s strange is that I fired up FF first thing this morning and it took until late afternoon to do the deed - without having restarted it. Almost 24 hours after I applied ‘my’ fix.

66.0.5 has just been released, using another approach to apply the fix.

thnx so much. all my addons working fine, for now.
People keep telling to get the latest version , but what the point when it not support the addons you use daily ?

In the same file (extensions.json). I think it’s right (1st or 2nd) before the “appDisabled”, for each add-on.

Yes, I noticed that to. Had set update to manually.

Only thing now is that they don’t show up in customize.

I don’t think it has anything to do with updates. I’ve had auto update turned off for some time now as I need to stay on a release that doesn’t cripple my most used add-ons. I think this still has to do with that certificate fiasco.

is mozilla envious of how bad microsoft are? are you actively looking for complaints? i rolled back to version 55 cos my favourite addons no longer worked and it’s still missing beauties like “hide tabs”, “roomy bookmarks”, “lastpass” “adblock origin” “noscript”, even your own tools are getting dirched, i can see “ask me every time” for cookies might be annoting to some, but i loved it, and you didn’t have to use it if you hated it, you dumped it? and now this “you have no connection” is just SILLY, utterly SILLY. get your act together.

Just a note on a temporary fix. Using 57.0 and linux. All I had to do is change “xpinstall.signatures.required” to false in about:config. Every add-on came back! Will probably change it back to true after the fix.

You really great! It works… hope forever…
thank you

After the 66.04 update Yesterday the addons appeared for couple of hours before they were gone again. Firefox still tells me they’re running - Let me tell you, THEY DONT!


Updated to 66.05… Some extensions work. Some extensions are completely gone (not previously legacy). And my old theme enables but is broken.

Ok… I’ve been patient long enough…

Where is the fix for 56.0.2 Linux 32b???

NO I can NOT UPGRADE my extensions don’t work in your “new versions!” Oh wait they don’t WORK NOW!

So where is the fix??? Where is the new cert to install???

Don’t want any more excuses about “trust chain!” Trust blew out the window a long LONG TIME AGO.

So lets cut to the chase?

Are YOU GOING TO FIX this for 56.0.2/32b/Linux? YES or NO?

Where is this fix?

I’ve tried numerous things and on this and none reactivate my ad block, cookie block/destroyer, so basically visting sites with FF is a threat. So I’ve had to find something that will work to do so till you fix it… 4 DAYS is time enough.

4 DAYS on a non Linux system is enough for those to be infested with enough garbage to be reimaged… Glad I don’t have to deal with this on non Linux…

So where is the fix???

So glad PaleMoon will be my installed browser on new boxes…

Have you tried changing “xpinstall.signatures.required” to false?

Well I made the updates again and this time it took only about 3 hours for FF to again disable those add-ons. This is getting really tiresome.