Thread: Add-ons not working due to certificate expiration

Where is to set active:true?

I see that there are any replies and infos anymore. Does it mean that it’s working for everybody?

FF 56 : the hotfix gone , all legacy addons working fine , others still disabled
still wating for fix

To me each add-on say that is damaged. I tried with Norton and Dashlane, but noone works.

Thanks for the tip.
I set all my extensions appDisabled:false, signedState:2 and active:true. Directly in extensions.json, since about:support does not let me make changes.
The new settings DO show in about:support though.

Now in Extension Manager they all show up as active again.
However, they still don’t work and they still don’t show their icons next to the address bar as usual.

My most important ones are AdBlock Plus and Video Downloadhelper.

Any ideas why they still don’t work?

Sorry … no idea. For me on FF56.0.2, all the previously disabled ones work.

Hey again,
found this video in another thread.

This worked for me and my extensions are back now.
Big thanks to all who helped.

And big BOO to Mozilla for being incompetent beyond belief.

1 Like

WTF!!! All previously re-enabled add-ons just got disabled again! On FF 56.0.2. WTF!!!

@TomP, we have to find a way to prevent Firefox to do its check list at startup.
As @freaktechnik said, every time we run FF, it checks all add-ons installed, locally and at server side.
I’m looking for a way to avoid that. To prevent FF to take decisions on my behalf.
I’m the right person to know what is better for myself. Not anybody else.

1 Like

More than just at startup. When I first experienced this several days ago, it was in a browser that I was using and had been open for about three days. I suspect that it also has a periodic check of some nature.

@grenouille7777, it sounds like a malicious code, like a real virus!
It’s very annoying that all we must to have a “father” to decide what we are allowed to use or not.
Too much easy if FF would leave everyone decide for himself…

Congrats! You guys have killed Firefox…guess it’s the day I have to move to Chrome…ughhh…thanks a lot…all my daily extensions are declared dead by you guys…so until you fix that, you’re declared dead/dying to me!

1 Like

Perhaps, from a certain point of view. But is it really any different from what Apple and Google do with iOS or Android apps? Or even the various Linux repositories to an extent? Well, maybe not with Linux as the checks don’t continue after installation…

Please make sure you’re on the latest version of Firefox, and if that doesn’t fix the issue, hang tight for announcements in [FIXED] Certificate issue causing add-ons to be disabled or fail to install

Agree totally. What’s strange is that I fired up FF first thing this morning and it took until late afternoon to do the deed - without having restarted it. Almost 24 hours after I applied ‘my’ fix.

66.0.5 has just been released, using another approach to apply the fix.

thnx so much. all my addons working fine, for now.
People keep telling to get the latest version , but what the point when it not support the addons you use daily ?

In the same file (extensions.json). I think it’s right (1st or 2nd) before the “appDisabled”, for each add-on.

Yes, I noticed that to. Had set update to manually.

Only thing now is that they don’t show up in customize.

I don’t think it has anything to do with updates. I’ve had auto update turned off for some time now as I need to stay on a release that doesn’t cripple my most used add-ons. I think this still has to do with that certificate fiasco.