Thread: Add-ons not working due to certificate expiration

is mozilla envious of how bad microsoft are? are you actively looking for complaints? i rolled back to version 55 cos my favourite addons no longer worked and it’s still missing beauties like “hide tabs”, “roomy bookmarks”, “lastpass” “adblock origin” “noscript”, even your own tools are getting dirched, i can see “ask me every time” for cookies might be annoting to some, but i loved it, and you didn’t have to use it if you hated it, you dumped it? and now this “you have no connection” is just SILLY, utterly SILLY. get your act together.

Just a note on a temporary fix. Using 57.0 and linux. All I had to do is change “xpinstall.signatures.required” to false in about:config. Every add-on came back! Will probably change it back to true after the fix.

You really great! It works… hope forever…
thank you

After the 66.04 update Yesterday the addons appeared for couple of hours before they were gone again. Firefox still tells me they’re running - Let me tell you, THEY DONT!

Hillarious

Updated to 66.05… Some extensions work. Some extensions are completely gone (not previously legacy). And my old theme enables but is broken.

Ok… I’ve been patient long enough…

Where is the fix for 56.0.2 Linux 32b???

NO I can NOT UPGRADE my extensions don’t work in your “new versions!” Oh wait they don’t WORK NOW!

So where is the fix??? Where is the new cert to install???

Don’t want any more excuses about “trust chain!” Trust blew out the window a long LONG TIME AGO.

So lets cut to the chase?

Are YOU GOING TO FIX this for 56.0.2/32b/Linux? YES or NO?

Where is this fix?

I’ve tried numerous things and on this and none reactivate my ad block, cookie block/destroyer, so basically visting sites with FF is a threat. So I’ve had to find something that will work to do so till you fix it… 4 DAYS is time enough.

4 DAYS on a non Linux system is enough for those to be infested with enough garbage to be reimaged… Glad I don’t have to deal with this on non Linux…

So where is the fix???

So glad PaleMoon will be my installed browser on new boxes…

rec9140
Have you tried changing “xpinstall.signatures.required” to false?

Well I made the updates again and this time it took only about 3 hours for FF to again disable those add-ons. This is getting really tiresome.

6 days and still no fix for this absolute atrocity.

How fucking incompetent are these devs?

All they have to do is make the certificate available for us to import and problem solved.

Instead they sit on their hands doing nothing preaching “upgrades” thinking we are all mindless beta testing sheep.

If there is not a fix for this by the weekend I am done with Mozilla. They have dug their own grave here.

More info on my previous post about changing “xpinstall.signatures.required” to false in about:config. Addons are still working fine, however now in Addons manager, above every one that came back Firefox now only warns. “…could not be verified for use in Firefox. Proceed with caution” Once the fix for older versions is available this warning, I assume will go away. Interesting that my version still allows the use of the addons without checking the certificates. I would like to know if anyone else was successful after trying this. It seems such a simple fix. Why are all the newbies running older versions having so much trouble?

You don’t think we haven’t already tried that?

It does nothing for most people.

The only person here you are outsmarting is yourself thinking that you are the only person that has mentioned or tried this.

2 Likes

My addons were working fine once I downloaded the initial fix, but now with 66.0.5 they dont work upon startup of Firefox. I have to go into the settings, and disable them then re-enable them for them to start working, I have to do this each time I start up Firefox.

Do you see any errors in the Browser Console before going to the add-ons manager after starting Firefox?

Newbie? Hardly… Know what a PDP8/e is? And how to boot it? I do.

Why do I use older verions?

Simple… MY EXTENSIONS don’t work since certain decisions to abanon them was made. No they won’t be replaced my the new webby thingys… they can’t be as the means to do it don’t exist.

So there is no point in going foward.

Additionally my web box for sites has other stuff on it that runs, and can’t be fussed with… Maybe I move it to something else in the future… but that means sourcing a box to do it…

This mess should have been a simple fix… Go here get these files, and put them here. Done.

The longer this goes the more I am inclined to come up with my own ideas on the reason for the “delay” in fixing this…

So by close of business on 5/10. I am done. I will begin removing FF from all my systems… Oh, did I mention I make that decision for more than me…FORTUNE 100… not a smart move… You already were on thin ice over the whole extensions mess… This is sort of the cherry on the cake.

Was already set that way, as its needed to instal my extensions to start with.

ok, I had found a fix that would bring back all my addons.
That was Tuesday.

Just now, they are gone again.

WHAT ARE YOU GLORIOUS MUPPETS DOING ??
The scale of your incompetence is truly staggering.
FIX THIS THING ALREADY !!!

Or find something else to do, since you are obviously out of your water and good for nothing.

1 Like

Hi stooney, what was the “fix” you used? You need a new certificate installed in your active profile in order to verify extension signatures so you can run and install extensions. So the issue could be that you didn’t install the certificate, or the certificate was removed, or you are using a different profile that hasn’t updated yet, or possibly the extensions.json file was rolled back to when the extensions were marked as unverified (which I think would be unlikely).

As a starting point, do you have the certificate listed in Firefox’s Certificate Manager? That can be viewed from the Options/Preferences page. In Firefox 56+, put cert in the little search box at the top of the page, click the View Certificates button, click the Authorities tab, scroll down to find Mozilla Corporation as a listed issuer. In Firefox 55 and earlier, go to the Advanced section, Certificates panel, then find the View Certificates button, etc. Here’s what you should see:

Got that? Need that?

Seems like every thread except this one is locked.

Where is this?

For anyone still experiencing issues in versions 61 through 65, we plan to distribute a fix through a user-installable extension. These extensions will not require users to enable Studies, and we’ll provide an update when they are available. (May 8, 19:28 EDT)

https://blog.mozilla.org/addons/2019/05/04/update-regarding-add-ons-in-firefox/comment-page-5/#updates

I updated My main system to 66.0.5 and now Google voice does not function.

I am not updating my laptop until THAT issue is fixed but I need those extensions fixed.

Forced updates are not a solution because not everyone wants to a moron beta tester for you or any other company.

Those of us that have been in this field for 3 decades know better and you still figured out how to screw us.

Great job.

1 Like

@jscher2000
I do not have any certificate from Mozilla in the list (FF 56.0.2)

My fix was this one and for two days it worked fine:

If they could deactivate and remove the certificate, surely they can re-install it as well?
What’s the problem with getting this fixed?

@stooney
https://www.velvetbug.com/benb/icfix/

2 Likes