Tp-link tapo P100

I am not able to add my TP-link tapo P100 smart plug. I have created an tp-link account and am able to turn it on and off from that. I then added the add-on for the TP-Link Tapo. Went into the config part and added in the username and password. I have tried to enter in the IP address to the addresses box (I have tried both with an address and without).
Any ideas of what I am doing wrong?

First thing to do is investigate the LOGFILE: settings -> developer -> logs, to see if any interesting errors are displayed… Physical files often at this location: ~/.mozilla-iot/log.

I removed the add on and then reinstalled it and this is the log file. It looks like it was able to go and and pull the files needed. (this is from the settings->developer-> logs on the UI)

192.168.1.10:80
2021-05-09 13:08:02.395 INFO : purpleair-adapter: Creating device for Inverness Park (20413)
2021-05-09 13:08:02.414 INFO : purpleair-adapter: Creating device for Walt Disney School Park (74841)
2021-05-09 13:08:38.788 INFO : Pairing timeout
2021-05-09 13:08:38.794 INFO : zigbee-adapter: Cancelling pairing mode
2021-05-09 13:09:48.517 INFO : Unloading TapoAdapter
2021-05-09 13:10:07.060 INFO : Fetching add-on https://github.com/WebThingsIO/tapo-adapter/releases/download/v0.0.1/tapo-adapter-0.0.1-linux-arm-v3.7.tgz as /tmp/Hb4JFc/tapo-adapter.tar.gz
2021-05-09 13:10:11.153 INFO : Expanding add-on /tmp/Hb4JFc/tapo-adapter.tar.gz
2021-05-09 13:10:26.384 INFO : Loading add-on: tapo-adapter
2021-05-09 13:10:50.467 INFO : About to call startPairing on ThingURLAdapter
2021-05-09 13:10:50.469 INFO : About to call startPairing on MicroBlocksAdapter
2021-05-09 13:10:50.473 INFO : About to call startPairing on WeatherAdapter
2021-05-09 13:10:50.474 INFO : About to call startPairing on ZigbeeAdapter
2021-05-09 13:10:50.477 INFO : About to call startPairing on PurpleairAdapter
2021-05-09 13:10:50.478 INFO : About to call startPairing on TapoAdapter
2021-05-09 13:10:50.485 INFO : microblocks-adapter: MicroBlocks adapter pairing started
2021-05-09 13:10:50.486 INFO : zigbee-adapter: Pairing mode started, timeout = 60
2021-05-09 13:10:50.496 INFO : Opened a new things socket