Upgrade/port incompatible unsupported addon

(Art.Wen) #1

Hi,

I have an old addon that i would want to use but it is only compatible with versions from 38.0a1 to 39.0

Can you provide information how i can upgrade/port this unsupported addon so it will work on the newest version?

0 Likes

(Jorge) #2

This might be helpful

0 Likes

(Art.Wen) #3

The problem is i didn’t develop this extension and have little knowledge about making extensions. Developer is inactive and i cannot contact him so i wanted to upgrade it myself. I have technical skills but need good information source(s) which doesn’t require great extension making knowledge.

0 Likes

(Jorge) #4

You can’t port an extension without extension making knowledge. If you want to try recreating the extension using the new, simpler API, you can go here:

0 Likes

(Art.Wen) #5

I mean i know that i have to learn some of that. But i wanted to get some source that will teach me about it in a way that port will be possible. So the best would be tutorial or few sources that doesnt require this knowledge at start. And that i would have to learn in and out of every technique cause that would be too much and better would be to create new.

But thanks for the second link that definitely will help.

0 Likes