"web-ext sign" command is timing out

Since 11/21/2019, we are seeing an error when using “web-ext sign” to generate our Firefox extension. There have been no code changes to the extension when the issue started occuring. The command has only been successful 3 times in the last ~30 attempts. When logging into our Mozilla dev account, we can see that all submissions have passed all of the Firefox extension tests, but the command is still failing. We’ve tried updating NPM and NodeJS to latest versions, but the issue still occurs. We specified a timeout of 20 minutes and still see the issue.

web-ext sign --api-key=user:******* --api-secret=********
Building web extension from C:\Users\Administrator.DELL123456\Desktop\New folder\dlpext\dlpext
Validating add-on […]

sign: Error: Validation took too long to complete; last status: {“guid":"fpdlpffext3@forcepoint.com”,“active”:false,“automated_signing”:true,“url”:"https://addons.mozilla.org/api/v3/addons/fpdlpffext3@forcepoint.com/versions/8.1.4402.102/uploads/12b670d85045423a9f29c791d2ac187e/",“files”:[{“download_url”:“https://addons.mozilla.org/api/v3/file/3460180/forcepoint_endpoint-8.1.4402.102-an+fx.xpi?src=api”,“hash”:“sha256:2e724be07ada0ca6f94627379f7e4a7fb9926ca34d429c8b031bcf20428cd961”,“signed”:false}],“passed_review”:false,“pk”:"12b670d85045423a9f29c791d2ac187e
at Timeout._onTimeout (C:\Program Files\nodejs\web-ext-master\node_modules\sign-addon\dist\webpack:\src\amo-client.js:222:16)
at ontimeout (timers.js:386:14)
at tryOnTimeout (timers.js:250:5)
at Timer.listOnTimeout (timers.js:214:5)

Hi @forcepoint_endpoint, it sounds like you may have encountered the timeout error from recent changes to the AMO submission flow. Have you tried updating web-ext to v2.3.1?

Hi Caitlin. I updated the version of web-ext last week to 3.2.1 and the “web-ext sign” command still fails.

I also see this failure frequently also:

Potentially unhandled rejection [1] Error: connect ETIMEDOUT at TCPConnectWrap.afterConnect [as oncomplete] (net.js:1129:14)

Pinging addons.mozilla.org at that time gives me the same IP address

Thanks @forcepoint_endpoint! The logs show the versions have been approved with no errors so far. The network error is a little weird and looks more like a connectivity issue than a problem with the API.

If this persists, can you file an issue on the web-ext repo?

In the meantime, are you able to successfully submit new versions through addons.mozilla.org?

Okay, I’ve opened an issue under https://github.com/mozilla/web-ext/issues/1773.

We are able to manually submit new versions through addons.mozilla.org. It seems like we won’t have a fix for web-ext sign right away, so we’ll have to change our build process to handle this step manually.