[WebExtensions] How to auto Pin webExtension Icon in default toolbar in Firefox 109?


I notice that our WebExtension icon is no more displayed in the Firefox toolbar
beginning with FF 109 version.
I have to click the ‘extensions’ button at top right to access it and re-enble display.

Is there some seetings to bring in the configuration to automatically re-enable it ?

Thanks for your advice :slight_smile:

I think this should do the trick - in the manifest file, under the “browser_action”:

"default_area": "navbar",

See the docs for more info:

1 Like

The docs currently say that “navbar” is the default. Since it’s a property that only Firefox supports I (and presumably others) have never explicitly defined it since the default behaviour was already correct.

It sounds like the default has been changed and the docs not updated?

Did explictly including the new property in your manifest file fix the bug for you @Bertrand_Perret1?

This was my source:

Default area of extension actions is now the unified extensions panel – Bug 1799947

(Bug title: browser_action’s without a valid default_area set should fallback to using AREA_ADDONS when Unified Extensions UI is enabled)

Hi Juraj, Chris,

Sorry for late responding,

I have just tested this setting in ‘action’ section, with V3 manifest.json

  • it works with Firefox Beta 110b3
  • it does work on FF 109


1 Like