Danfos thermostat and Aeotec Z-Stick half working

I paired an Aeotec Z-Stick 5+ and a ZWE Connect / Danfos thermostat and installed the Webthings gateway image on a rapberry Pi4. This is all working fine. On the Things page I pressed ADD. Through the Z-Stick the thermostat is registered as zwave-e2fdcb66-5-Thermostat but it reads always zero degrees. In settings | developer | view internal logs I see:

zwave-adaptor: node 5: node awake
zwave-adaptor: node 5: node sleep
zwave-adaptor: node 5 value changed: 5-49-1-1: Air Temperature = 15.15 C (no property found)
zwave-adaptor: node 5: node awake
zwave-adaptor: node 5: node sleep

Conclusion: the correct temperature is read but not brought forward to the Things page. Is this due to a incorrect driver or something else.

On the thermostat E5 is displayed meaning: The thermostat is not receiving the expected replies from the control system.

It would be great if you can help me further, thanks.

Thanks for reading.
I did found the solution, it is / was a driver problem. On the Settings | Add-ons page is a Z-Wave area with an update button. After update the application is working as expected.

1 Like

I am experiencing the same “temperature is always displayed as zero”, with almost exactly the same setup - an Aeotec stick, and a couple of Danfoss Living Connect Z thermostats.

Unfortunately, I see no “update” button anywhere…

I’m a bit lost in the internal logs (which are already super-long) but as best as I can tell, the thermostats’ temp values are there, just like the O.P. My 'stats aren’t displaying any errors, though.

Any help / tips greatly appreciated!