Zwave ZStick stops working after 1st reboot


Looking for some help, After a succesful image and setup I can add my zwave devices and they work great. Until I reboot then they all stop. I have re-imaged and set back up my devices probaly 3 times now and always after a reboot everything stops again. Here is the part of the log where the zstick is failing to start and its stuck in this loop. Any ideas?

This keeps repeating:

2019-07-23 19:12:49.618 INFO : Plugin: zwave-adapter died, code = null restarting…
2019-07-23 19:12:50.307 INFO : zwave: Opening database: /home/pi/.mozilla-iot/config/db.sqlite3
2019-07-23 19:12:50.349 INFO : zwave: Loading add-on for zwave-adapter from /home/pi/.mozilla-iot/addons/zwave-adapter
2019-07-23 19:12:50.709 INFO : zwave: DEBUG config = ‘’
2019-07-23 19:12:50.733 INFO : zwave: Closing database
2019-07-23 19:12:51.060 INFO : zwave: Found ZWave port @ /dev/ttyACM0
2019-07-23 19:12:51.066 INFO : zwave: Initialising OpenZWave 1.6.0 binary addon for Node.JS.
2019-07-23 19:12:51.068 INFO : zwave: OpenZWave Security API is ENABLED
2019-07-23 19:12:51.076 INFO : zwave: ZWave device db : /home/pi/.mozilla-iot/addons/zwave-adapter/openzwave/config
2019-07-23 19:12:51.078 INFO : zwave: User settings path : /home/pi/.mozilla-iot/log
2019-07-23 19:12:51.079 INFO : zwave: Option Overrides : --SaveConfiguration true --ConsoleOutput false
2019-07-23 19:12:52.892 ERROR : zwave: Unhandled OpenZWave notification: 30
2019-07-23 19:12:52.930 ERROR : zwave: Unhandled OpenZWave notification: 30
2019-07-23 19:12:52.977 ERROR : zwave: Unhandled OpenZWave notification: 30
2019-07-23 19:12:52.979 ERROR : zwave: Unhandled OpenZWave notification: 31
2019-07-23 19:12:53.198 INFO : zwave: Driver Ready: HomeId: c13643d6
2019-07-23 19:12:53.207 INFO : zwave: node1: Named AEON Labs ZW090 Z-Stick Gen5 US
2019-07-23 19:12:53.209 INFO : zwave: node1: name="", type=“Static PC Controller”, location=""
2019-07-23 19:12:53.211 ERROR : zwave: terminate called after throwing an instance of ‘OpenZWave::OZWException’
2019-07-23 19:12:53.213 ERROR : zwave: what(): Manager.cpp:1768 - InvalidValueIDError (101) Msg: Invalid ValueID passed to GetValueLabel
2019-07-23 19:12:53.219 INFO : Plugin: zwave-adapter died, code = null restarting…

I’ve seen this once before, but for the life of my I can’t remember what the problem was.

I’d try going into /home/pi/.mozilla-iot/log and renaming the ozwcache_0xXXXXXXX.xml file and see if that helps.

Unfortnately, I’m just about to go on vacation for a couple weeks and will have limited internet access, so won’t be able to help much more with this until I get back.

I’m getting the same error.

Deleting the file, as Dave suggests, works.

I have not found any documentation on how to use z-wave with the WebThings Gateway, can I add devices directly from the web ui?

So far I’ve just plugged out the z-stick and added them with the manual inclusion mode, put it back in the PI, and then rebooting the gateway.

Glad to hear it worked, I’ll have to give it a try.

What’s been working for me is hitting the plus button on my phone right next to the new device. Then physical pressing any buttons or if it’s a like a door sensor opening and closing. Usually will see a new device appear right after in the list.

It worked! The names of all my devices went to undefined after this, but clearing the cache on my browser seemed to fix it. Thanks!

The way I add zwave devices is to hit plus in the UI (from the Things page) and then follow the inclusion process for the device you want to add. Typically this is pushing a button on the device being added. For devices which have previously been paired, they’ll need to be factory reset first.

I see from your original message that you’re hitting an error in the OpenZWave library. I’ll see if I can reproduce this.