Enabling SSH and then access is denied

Can anyone confirm if ‘ssh’ for Gateway V1.1 is actually working.
I had previously used ssh for access to fix and install scripts for the Argon One V2 case which uses a speed controlled fan. The fan scripts previously worked for V1.0, but I have now found that when I updated the Gateway to V1.1, the scripts no longer work. I need to access the terminal, via ssh. Unfortunately I now get ‘access denied’ when using Putty via ssh.
Previously for V1.0, I had no issues.
Thanks in advance.

Hi @Antonio_Benci,

Sorry you’re having issues. I’ve just tested on two different WebThings Gateway 1.1 installations (Raspberry Pi image) and SSH worked for me using the command line SSH client on Mac and Linux (though I haven’t tried Putty). I’m also able to disable and re-enable it successfully.

A couple of things to check:

  • Check that SSH is enabled in Settings -> Developer in the gateway UI
  • SSH will only work on your local network (local IP address or gateway.local only, unless you’ve configured your own DNS and port forwarding), it won’t work via the webthings.io tunnelling service
  • Check if you have a public key cached for gateway.local (or your gateway’s local IP address) in known_hosts (I’m not sure where that is on Windows). If you have then try deleting that line of known_hosts and try again
  • Sorry to suggest the obvious, but are you definitely using the right password? You can check this by logging in to the device via a keyboard and mouse or serial console

If it still doesn’t work then please file a bug with steps to reproduce.


Hi Ben.

Finally able to reply after recovering from a shoulder reconstruction. I’ll address each point.

1: SSH is ticked and enabled.
2: Access is though local wired connection. Tested and confirmed.
3: Found “known_hosts”. for Win10, if using PowerShell for ssh connection, it is located at "c:\Users~.ssh. The file was deleted. Then retrying ssh, a new key was associated.
4: I have tried all the know (and unknown) login and password combinations that I can think of. Including the default pi/raspberry. No Luck

I have tried SSH with PowerShell, PuTTy and kitty (PuTTy variant). I’ll file a bug.

Thanks for taking the time to reply.