IoT Gateway on RasPi crashes when clients try wireless connect


being just a user of linux with very little knowledge of architecture and programming and an absolute freshman in IoT I put my Mozilla Gateway installation troubles to discussion and hope for any hints to solutions from the community.
Unfortunately I can’t access my Pi 2B serially yet and do screenshots other than photo or video of the screen but EVERY time I try to connect a client (linux, windows, android) to the WebThings Gateway XXXX the server throws 2 or 3 pages of messages and is unresponsive both to web and keyboard requests. Sometimes after the innumerable and unavoidable cold restarts the file system on the µSD gets corrupted so that I have done over a dozen etches of 3 downloads of (SHA256 checked OK in each case) on different (new) µSDcards, boards Pi 1B+, P2B 1.1 (mainly) and P3B without success in the last days and nights.
I am wondering whether I need to attach a CUL, Zwave or Zigbee or such prior to accessing the server?! Current issues may be of import but I have tried with different power supplies from nominal 2 to 3 Amps without success.
Instead of a log or trace file I can only furnish a video clip of the event, in case so. should be interested.
AFAI can see the messages begin with a “kernel bug at mm/slub.c:3904!” followed by listings of modules, flags, stacks etc. Video footage or screen shots available on request. :wink:
My hardware setup:

  • RasPi (1, 2 or 3)
  • Keyboard (105 key)
  • HDMI to display panel
  • EdiMax EW-7811Un WiFi dongle

Thanks in advance for any comments, requests and speculations.

It looks like you’re running into a kernel panic, probably because of your Wi-Fi dongle’s driver.

Hello, MrS.

Thanks for your diagnosis/assumption.

Yes, the screen tells me of a kernel panic (ending) a few lines before the end of the scroll. I forgot to mention that. :frowning:
I wonder why I’ve never experienced this behaviour before, but truth be told, I’ve never before in these 4-5 years operated the EdiMax as access points.
So maybe there is a flaw in the system regarding this functionality. Unfortunately I do have but 2 dongles, both EdiMax and very probably using the same driver.
I just checked the web for an eventual flaw and found out that Realtek chips tend to fail for Access Points. Yet my EdiMax 7811Un with its Realtek(?!) chip and the on-board WiFi of the Broadcomm should both work.
Since I used a Pi3B first, then the Pi1B+ and finally the Pi2B and all crash similarly or even identically, I’ll wait for the newer Pi4 with its on-board wifi that should be in the mail by now.
Thanks again.

Further reading in Pi related forums showed me that one has at times to act in discordance with the FAQ and manuals and I remember reading of the importance of the (WiFi-)Country= setting and inserting pauses in scripts (apdhosts) among others but since I did not find any hints in the IoT Getting started I’d expected the gateway to work out-of-the-box.

I do not yet know whether links to images are to be avoided here.
So here is a video frame from my kernel’s panicking and trace for those who care to wreck their brain:

shows the first lines of dump with -among others- the message:
… kernel BUG at mm/slub.c:3904
… Internal error: Oops = BUG: 0 [#1] SMP ARM
… et al.
A video (coarse) shows everything till [end trace …]

Just this very moment I found 2 references probably to exactly my issue on github, the workaround or solution possibly lying in the deletion of blacklisting file rtl8192cu.conf from /etc/modprobe.d:


So I will try removing blacklist-rtl8* files (if present) from /etc/modprobe.d/ and get back with the result some twelve hours from now.


Here the update as promised:
After the deletion of “blacklist-rtl8192cu.conf” the AP from before has not shown up any more. Still not being able to connect the WT gateway to my home wireless network I set IP for WT gateway, DNS and internet gateway by command line before
I apt-updated&-upgraded the system. After some experimenting with the web front of the IoT gateway (after all that’s what I am undertaking this install effort for) I decided to give a new image a try. This time I deleted or moved the said file AND all directories by name of rtl8192cu (and their content) prior to the initial run because I wanted the system to resort to other drivers if possible. Sadly the wireless interface was just not installed and that’s the state of the affair for now.
Browsing the web I found much OS and version dependent guidance which AFAIK either did not apply or which did not work for me. I assume I’d have to modify the wpa_supplicant.conf on the newly etched image. This I would rather not do because I prefer auto-configuration over tinkering/tampering if possible.
Any hints so.?

Do you have another Wi-Fi dongle you could try, that doesn’t use third party drivers? I’ve never had great luck with them.

Sorry , Mr. S.
but No is the answer (still).
As I wrote earlier I have no other than the 2 EdiMax and do not know of a dongle in my vicinity, would have to spend a few hours on procuring one. Since I could resort to Ethernet I may run the gateway from there. In the meantime I think I may try and git the gateway on top of a Raspbian installation, so that the Pi can be easily and put to other uses besides (streaming audio/video from the TV receiver for instance).
I’d gladly try a different dongle but it is not an urgent matter as the whole IoT business is yet a vision of mine with less than a dozen actors and sensors at present. I am comparing and studying the different concepts and realizations of systems for automation and unified control of my 433 and 867 Mhz devices and experimenting with the setup and operation of the newer devices (mostly Sonoff under Tasmota) themselves.

Many thanks for your commitment, Mr. S.