IP address has been blocked, can't submit a new add-on


I posted the same question on the Support Mozilla forums, but I only just found this place, which seems more appropriate for it.

I recently submitted a new add-on, which has just been accepted and added to the store. I’d like to submit an alternate version of the same add-on as another extension, but I haven’t been able to. The first add-on provides two features, but one of them requires access to web requests; the second add-on removes that feature entirely and therefore does not need to access anything (other than a button press), hence why I’d like to add it as another, separate extension.

The first submission went smoothly, no issues at all; however, today after making the necessary changes to the add-on to make the alternate version, I tried submitting it and have been unable to because Multiple submissions violating our policies have been sent from your location. The IP address has been blocked. . I’m forced to use a VPN, and I assume this the reason why I’m getting this error message.

I’ve tried restarting my router, changing my location on my VPN, or briefly turning off my VPN, even using another computer, but it always results in the same error message after doing the captcha, preventing me from submitting the other add-on. What can I do?

I assure you I’m not a bot – although that’s probably what a bot would say in this situation…

Thank you.