Login issues with VPN

I had all sorts of difficulties signing up with the Mozilla Discourse site, but finally found my VPN (Private Internet Access) was the major culprit. This took me a while to figure out since I use several Discourse sites and have never had any issues logging in.

With Mozilla’s Discourse I was unable to login through any of the available methods while connected to the VPN. Each time I input my credentials, or followed the email link, I received the generic error message:

discourse-mozilla-login-error

Once I guessed it might be a VPN issue, I logged into the Mozilla Discourse without the VPN and then, once I was logged in, I connected back to the VPN. This worked, but I was wondering:

  1. Is there are simpler solution to this issue?

  2. Is there a way to alert users that login issues could be related to a VPN?

1 Like

Hey @skinny852, thanks for reporting this.

I signed up for a Private Internet Access account to test what was happening, and I also get the error. Of the locations I’ve tried only “US Silicon Valley” causes the error (which seems to be the same location you were using looking at your IP address). So try with another location, and you should be successful - “US West” works for me.

@kang this block seems to be happening on the Auth0 level, I also get an error when trying to log into https://sso.mozilla.com.

When logged in from “US Silicon Valley” the request to:
https://auth.mozilla.auth0.com/login/callback
in the login flow redirects to:
https://discourse.mozilla.org/auth/auth0/callback?error=unauthorized&error_description=Access%20denied.&state=blah

Is it possible Auth0 is blocking IPs on the 199.116.118.xxx subnet? Is there anything we can/want to do about it?

1 Like

hi,

when there are attacks from large ranges of addresses these may get blocked from some amount of time for our systems. This happens more often with VPN providers that attackers use unfortunately.
When you get this message that’s exactly what’s happening

1 Like

Yes, using a different VPN server location worked for me today.

Thanks for investigating, @leo.

1 Like