Need help with Zigbee-adapter Add On + http request

Hi all,
I am trying to make a http request when I get an update from a zigbee device (smartthings motion sensor). So I thought I would start from the zigbee-adapter addon and make some modifications from there to test.

I followed the instructions here “Creating an Add-on for the Project Things Gateway” and cloned the zigbee-adapter. When I ran the gateway, a bunch of errors came up when loading the zigbee-adapter. With the first one being:
ERROR : zigbee: { Error: Cannot find module ‘serial-prober’

Being new to this, I wasn’t sure where to start and decided to post a question here. Any advice or guidance would be much appreciated. Thank you!


You probably just need to run npm install inside the zigbee-adapter directory.

The serial-prober is a dependency of the zigbee adapter (mentioned in the package.json file).

You shouldn’t need to make any changes to any of the adapters. They all provide notifications to the gateway when things change. You can use the REST API and websockets to get notified of thing changes, regardless of which adapter is being used. This is how the gateway UI does it.

@mrstegeman Thanks Michael. Is there a difference in just running npm install and running the package shell?

The script is used to create the add-on package for distribution. For doing local development, npm install is what you want.

1 Like

Hi Michael,

I have got a follow up question to the custom zigbee-adapter.

I just noticed that when I am running the gateway with the github version of the zigbee-adapter, the smartthings sensor doesn’t show up on the gateway interface although the sensor did pair and there is sensor data coming through as seen on the logs. Any idea, what I might be missing or doing wrong? Thanks!

What do you mean by “doesn’t show up”? On your main Things screen, or are you unable to add the device to your gateway?

Hi Michael,
I attached a couple of screenshots. There’s the main Things screen which says “No Devices Yet” and a logs screenshot which shows sensor data from my smartthings sensors being logged followed by the http requests I wanted to make.

A quick follow up:

I tried adding another motion sensor and now it seems to look normal again on the main Things screen. Not quite sure what happened but I think it’s good for now.
Thanks again!