[SOLVED] The gateway on docker not found device


I’m running mozilla iot with docker, however when try to scan for devices, it doesnt found anyone. I installed it on raspberry, and that work for me, but now I need to run it with docker for another project.

My device is a NodeMCU and I have a dht22 temperature sensor.


We don’t currently have any webthing libraries that support NodeMCU. Are you doing something custom? Are you hoping to use the “Add by URL” functionality?

Ok, maybe that is the problem for NodeMCU. However, the docker image don’t have “add by url” functionality, just the native image for Raspberry pi.

I tried with docker image for ARM in raspberry and x64 for my laptop, but both can’t add by url.

In order to use the Add by URL functionality, you need to have the Web Thing add-on. That is preinstalled in the RPi image, but not the Docker image.

Regardless, for that to work, your device needs to conform to the web thing spec. That is what our webthing libraries do for you.


I installed the Web Things add-on and it’s worked!