[Support] uBlock Origin


#287

I’m experiencing a bug with uBlock Origin. Updating to 1.10.6 did not correct the bug. I’m using Firefox Developer Edition 52.0a2 x64 on Windows 7 x64.

If I click the uBlock toolbar button, the button shows a Button Down pressed state while the main uBlock panel is up. If I click outside of this panel, it closes, and the toolbar button resumes its Button Up unpressed state. This is correct behavior.

However, if I go into any part of uBlock that opens a new tab (e.g. Options, Logger, etc…), then the toolbar button does NOT resume its Button Up unpressed state. Even if I close the tabs that got opened, the toolbar stays in its Button Down state, and it is no longer functional for the life of that browser window.

The only way I can get into uBlock again is by opening another browser window.


(Eugene) #288

I’m too support the user Spike44. I’m too experiencing a bug with uBlock Origin. I’m using Firefox 51.0 x64 on Windows 7 x64. In some cases ublock crash and close, icon on panel disappear and stop blocking ad. Only restart browser can help for some time. Check this bug please. Thanks )


(Raymond Hill) #289

Please look at the browser console when this occurs, there could be errors reported in there related to this. I can’t reproduce using FF50 or Nightly. Also, see if the issue also occurs without any other extensions installed – i.e. with uBO being the only extension.


(Raymond Hill) #290

Looks like a different issue, unrelated to the toolbar button issue. Advices are the same however: open the browser console to see any errors reported when this occur. Also, try as uBO being the only extension: disable all extensions except uBO, restart the browser and see if this still happen.


#291

iam too experiencing same issue
[URL=https://github.com/gorhill/uBlock/issues/2341]ISSUE[/URL]
[URL=https://github.com/gorhill/uBlock/issues/1379]ISSUE LIKE THIS[/URL]
PLEASE fix


(Eugene) #292

Yes, thanks ) Mail.ru extension conflicted with ublock, I was deleted it )


(Maysun) #293

I don’t see where I can start a new topic or ask questions…but how do I unblock rtlxl.nl? It does not play video anymore.


(Steven) #295

I read your GitHub contributing document and it lead me here. Please redirect me if this is the wrong place to ask. But I would like to discuss issue 2029 since it was closed on GitHub.

Instead of throwing, could you just return instead? Maybe even console.info('aborting content scripts') instead of throwing since this isn’t really an error.


(practik) #296

Yahoo Mail users in the U.S. have to contend with a gigantic TurboTax banner ad that appears at the top of the page around this time every year. uBlock Origin blocks the ad just fine, but the blank space that’s supposed to be filled by the ad remains at the top of the page. Here are the two filters I’ve come up with to make that space go away:

mg.mail.yahoo.com##div#uhWrapper:style(margin-top: 0px !important)
mg.mail.yahoo.com##div#main:style(top: 94px !important)


(Indos3) #297

There is some conflict between Ghostery and uBlock.

ID: cjpalhdlnbpafiamejdnhcphjbkeiagm


#298

Seems AMO hasn’t published version 1.11.0 after 6 days (would normally be up by now). Given that there’s a bunch of Firefox changes included, I’m starting to think that something has gone wrong somewhere.


(Raymond Hill) #299

Simpler explanation:

Next Listed Version: 1.11.0
Queue Position: 114 of 181

Reviewing extensions is hard and time consuming work, please be patient.


#300

Hello!
I need to add Several Filters for the “My Filters” Tab . . . However, the ENDING of the URL they apply to changes frequently. Do I use some sort of WILDCARD to catch ALL those changes??
Here is an EXAMPLE::
Https://TopSecret_Lair.ca/CodeBngj8lQzYe5vT
AND
Https://TopSecret_Lair.ca/CodeCng4ql5Ye5xM

On Very Next USE, BECOME::
Https://TopSecret_Lair.ca/CodeVqUkCm6ZxFb
AND
Https://TopSecret_Lair.ca/CodeZVUkqCm6ZxFb

In Other Words, ONLY the Final 12 Characters always change,
so I guess I need my Filter to be something LIKE::
Https://TopSecret_Lair.ca/*

Can I just add that asterisk?
Thank You for your Help ! !
Chuck


(Antonioaltamura) #301

I noticed uBlock breaks Angularjs applications because it blocks this
https://github.com/revolunet/angular-google-analytics module.
Since the dependency is blocked the whole application doesn’t work.


(Raymond Hill) #302

This is because of a filter in EasyPrivacy (you can see this with the logger). Report whatever specific false positive you experience to EasyPrivacy maintainers: https://forums.lanik.us/viewforum.php?f=64.


(Raymond Hill) #303

Try ||TopSecret_Lair.ca/Code*.


#304

Thank You, Mr. Hill!
You are a Champ!
And uBlock Origin is surprisingly good. I had, for a long time, used Two other adblockers before discovering uBlock — and yours is easily superior. I truly believe that if people could somehow be persuaded to merely try uBlock, the competition would be toast; but people simply do not know about the difference!


#305

Hey gorhill, many thanks for this wonderful addon. However, there are 2 sudden issues I am having and I noticed many threads of a similar nature on reddit and the like:

  1. Unfortunately, in the past few months there has been a sudden spike in CPU usage, to the point that my fan is just screaming until I disable uBlock.

I know you get these a lot but please bear with me because it really is very confusing, at least right now.

There is no “specific” reproducible case because it happens all the time, regardless of which website I am on. This issue did not exist 3-4 months ago. I haven’t messed around either, besides using the addon as would be normally expected.

  1. uBlock doesn’t seem to “work” properly anymore. Let’s say I am on a forum where people have attached pictures of their wallpapers or anything else using different imagehosts. What happens is that many imagehosts get filtered so I would enable them in the advanced menu. But now those don’t work properly; some images still get filtered out (is this because of specific “3rd party filter lists” instead?).

Once I got tired of it, I set “all” as green for the local section of the website. It was working fine, but then it suddenly stopped working. uBlock wouldn’t respect it anymore. So finally I tried to see what would happen if I disabled uBlock from within the addon (not disabled from Firefox). It would work and then even that has stopped being respected. It seems like a pattern where first everything works fine for a new site and then once I’ve visited enough times, it would stop respecting anything. What’s so weird is that the addon is disabled from within the addon and it would not matter; things would still get filtered.

The only solution was to completely disable the addon from about:addons. The unfortunate side effect is that all those insane pop ups and things come about that eat up nearly the same amount of processing power.

Hope to hear from you soon! Normally I tend to figure these things out on my own but this is quite baffling. Maybe it’s the newer Firefox versions that are causing this? Mine is 51.0.1. Also, I use Privacy Badger, but I haven’t noticed any conflicts with uBlock.

Kind regards.


(Raymond Hill) #306

Some web sites may behave erratically when some stuff is blocked – including CPU spikes. The only and only way to make the case that there is an issue with uBO, is to actually provide supporting evidences. There is no other way. No report of such issue exist – so it’s simply not true that I “get these a lot”.

I can’t help you: without specifics, it’s impossible to say anything of value. There are no reports of such weird behavior. I notice that you did not mention at all the logger, while this is the tool to use in case of filter/rule issues.

Here are two key points, without which nothing productive can be done:

  • The logger, use it.
  • Specifics: provide all the steps for others to reproduce.

Without this, it’s impossible to claim that uBO is not working properly, in all likelihood this will be the wrong conclusion.


#307

How to enable element picker on mouse right click menu ? When I first installed ublock origin I had the ability to right mouse click on the page and there was a menu item for the element picker.

It seems to be no longer available and I would like to re enable it, but I don’t know what I did to lose it.

I have checked the box for “Make use of context menu where appropriate”

Any instructions on how to get that feature back ?