The function "Download Translations" of Pontoon doesn't work


An error occurred when I clicked on the “Download Translations”, I have tried many times but got the same result.

Please take a look at the screenshots below:

The function should work, project’s configuration is probably broken. Can you provide a screenshot of that? The only relevant one is Repositories

Thanks for your response! And the Project info is as follows:

Sent you a DM, as I need to see the actual repo if possible. Not sure how visible the notification is in the UI, as it’s the first time I use them in Discourse.

Sorry, I really don’t know how to help with this information (the repository is private, and you blurred all the relevant paths in the pictures).

Do you actually have locale folders in the root of the repo? Are these subpaths identical across locales?

For example, for this project, Pontoon is set up with{locale_code}/

Please take a look at the unpainted picture:

Hey @Panda, any chance you could make the repo at public temporarily or give my GitHub user (mathjazz) access to it? That way I can help debug the issue.