"No Element selected" in CSS Inspector

This issue is the same like in Inspector: "No element selected" (No CSS) but since the last update to 77.0b3 (64-Bit)
On the websites I am working on the CSS Panel is empty and shows no Stylesheets at all. Some websites work, some not.
I tried also in Save Mode, Reset all settings etc. but that did not help.

@elisasophia hi

Can you try to open the Browser Console and see if there are errors logged there? (Tools > Web Developer > Browser Console).

Do you reproduce the issue on a public website we could use to test? If not, can you share some more info about the kind of websites you are working on (are you using hot reload, specific frameworks or tools etc…)

Thanks

1 Like

@jdescottes Thanks!
The Browser Console only shows Warnings, no errors. You can test on “///removed example url///” for example. Can you reproduce it?

Edit: I switched to Firefox 76.0.1 (64-Bit) to be able to continue working and initially it worked there. but now the same bug like in the developer edition…

Thanks for the info!
I can’t reproduce the problem so far.
I have tried to open the inspector both via the “Inspect Element” menu item and using a keyboard shortcut.

If you try to select another element in the inspector’s markup view, do you still see “No element selected”? Don’t hesitate to add screenshots and to share the exact steps you are using to reproduce the bug.

Thanks.

Yes in the beginning the css inspector is completely blank, after browsing on the website and clicking through the elements it always shows “No element selected” and “No CSS-Properties found”

I am working on a Joomla Website Template, having scss compiled into a template.min.css. Last year I had the same issues but I could use the inspector after restarting the browser or opening a new tab. This time it does not help at all.

Thanks for the additional details!
I still can’t reproduce the issue, so I will create a Bug to get more eyes on this.

I filed https://bugzilla.mozilla.org/show_bug.cgi?id=1636660

Did you also try with a clean profile? (https://developer.mozilla.org/en-US/docs/Mozilla/Firefox/Multiple_profiles)
If it works with a clean profile, attaching the information from about:support on the faulty profile could help investigating.

A clean profile seems to help - what could be the reason here? Thank you!

Glad it was useful!

Hard to say what the issue could be with the other profile. If you still have access to this other profile, can you go to about:support, use the “Copy raw data to clipboard” and attach the output here?

The issue re-apeared with the clean profile now too…
Then I switched the profile back to another one, and it did not help, today I restarted my browser and it works in all profiles. Maybe switching the profiles did not really help and it was only coincidence …

Now it works everywhere, If it stops working again I can paste the data…

Elisa is not the only one. This problem has appeared randomly for me several times over the last few months. Once it starts claiming there is no element selected, it will continue that way during that session of browser use and perhaps longer - it’s hard to predict what will shake it loose. It might be memory-related, but I’m not sure.

1 Like