SmartThings Device Does not Work

Have a SmartThings plug. I have tried everything to get the device noticed by the Gateway, but to no avail. Interestingly, adding the Samsung app to my phone, I was able to get the plug set up and start controlling it within a minute.

I’ve tried re-pairing the device, locating the IP address and adding the device by URL, removing and re-adding the Ziggby and Conbee add-ons (I have the conbee ii dongle inserted in raspberry pi). Nothing works. The gateway just doesn’t see it. Any help will be appreciated.

I’d just like to get the gateway to recognize this one plug. I’m assuming the sequence is… 1) get gateway running with conbee II dongle in the usb of raspberry pi III; (2) plug smartplug in wall; (3) add conbee add-on or ZigBee add-on; (4) click to add a thing; (5) gateway recognizes thing.

Am I wrong or missing something? I’ve worked on this for >10 hours over the last three days and fear I am in a mental Do-While loop with a perpetual Readystate of 3.

For all Zigbee devices, you have to factory reset them (or buy new and not paired to anything else). If you have the SmartThings hub or some other Zigbee hub, probably easier to turn it off while switching your Zigbee devices to the WebThings Gateway.

I have this version of the Samsung SmartThings plug and it works fine with Conbee and Digi X-stick:

Here are the factory reset instructions:

  1. Hold the connect button for five (5) seconds
  2. Release the button when the LED flashes blue 3 times
  3. The LED will blink red and green while attempting to connect

So when you see the red/green blinking, click “+” on the Things page and wait. If it still does not succeed, fetch zigbee-related info from the log during the scanning process. Either Settings > Developer > View Internal Logs
or access via ssh or console:
$ tail -f ~/.mozilla-iot/log/run-app.log.DATE_OF_MOST_RECENT_LOG

Thank you for your response. I have this Smartthing plug which only has a green light (intermittent state before pairing, solid after), with a brief red light to signify factory reset:

It’s the cheaper Smartthings plug, so I may be out of luck. I’ll try again though. I did get my color Philips Vue lights and Kasa (TP Link) plug connected. The process for both of those involved, in addition to grabbing the add-ons, resetting the devices and, in the middle of pairing them to their respective phone apps, clicking on the “+” to add a thing to my gateway. That small window of time, I’ll refer to it as the pairing queue time, was crucial to tethering those devices to my gateway.

Ah, that’s the Wi-Fi one, not Zigbee. Probably needs an add-on written for it to translate its API into a standard web thing switch or smart plug.